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Open Contour

Info buttons 
can be found 

throughout the 
program and 

can be helpful 
guides. Click on 

this one.

Tip: don’t 
start this at 
5 pm on a 

Friday.



This specific info button tells 
you where your files are 

going to be saved. Note it 
down.

Let’s create a new workspace with the 
easy_example.tif file available at 

https://github.com/kamallouisnahas/Contour.

Download the file if you haven’t already. Then 
change the workspace name. 

https://github.com/kamallouisnahas/Contour


Global segmentation

Now we’re going to 
segment the whole 

tomogram in one go.



Click on New workspace, select the file, and open it.
The image must be an 8-bit tiff stack and not an mrc file (e.g. rec).
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A bunch of windows should pop up.



Alter your display settings if you need more space on 
the screen. On a Mac, go to System Preferences > 

Displays > More Space.

The Log window allows you 
to track processes.

The blue scroll bars in the Imported 
Image window and Preview 

Segmentation window allow you to 
scroll through the Z stack.



We’re going to segment 
the mitochondria based on 
their projection intensity.

Click on Eye dropper.

Now shade the inside of a 
mitochondrion – do not 

shade the edges.

Left click with the mouse 
and hold down to shade.

The intensity of the voxels 
being picked up by the eye 
dropper is displayed on a 
histogram at the bottom.

Shade in until you feel 
you’ve collected the full 

intensity range.



Click on Preview in the 
Preview Segmentation 

window.

The voxels within the 
lower and upper limits 
of the threshold range 

will appear black.

The threshold range is 
displayed in these entry fields.

These pink lines show 
the threshold limits set 

by the eye dropper

Hover over the pink lines in the 
Preview Segmentation window and 

you can see the intensity value in the 
Imported Image window



You can use the 
mouse to move the 
pink lines and alter 

the threshold range.

Here the upper line 
has been moved to 

the left, picking up a 
smaller range.

Here the upper line 
has been moved to 
the right, picking up 

a larger range.

The threshold values 
readjust when you 

move the lines.



If you click on the 
Lock button on 

either window, the 
z stacks will be 

synced. You can 
scroll through 

both at the same 
time with either 

blue scroller.

This is useful if you 
want to preview 

the segmentation 
in other slices and 

readjust the 
threshold range 

with the Eye 
dropper.

The values in the Threshold 
entry fields will readjust.

Whatever values are in these 
fields will be used in the 
segmentation. You can 

manually alter them if you 
wish.



Once you’re happy with the 
threshold range you’ve 

selected, move on to the next 
parameter: Minimum width.

Type in 4 for these 
mitochondria. 

After the threshold range is 
used to segment the voxels, 

the minimum width will filter 
the data so that only 4⨉4 
matrices will be included. 

This helps to reduce noise.

You don’t have to use a minimum 
width. Try segmenting the lipid 

droplets later without a minimum 
width.

Click Segment



Check the status in the Log window.

Once complete, the Segmented 
Volume window will pop up.

Reminder: 
these info 

buttons are 
helpful.



Local segmentations

Now we’re going to 
inspect the global 
segmentation and 
make corrections.



You can see that most of 
the mitochondria have 
been segmented but 

there are a few areas that 
have been missed.

Click View segment to 
toggle ON/OFF the display 
of the segmented volume.

Click View source to 
toggle ON/OFF the display 

of the imported z stack.

Let’s fill in this 
area first.



First, use the scroll bar to find the Z limits of the feature you 
want to segment. In this case the limits are 1:6 (i.e. the whole Z 

stack) so we don’t need to change any parameters.

If you did want to change the Z limits, 
you could do so with these tools.

Current sets both limits 
to the currently-
displayed slice.

Start resets the 
lower limit to 

slice 1.

End resets the 
upper limit to 
the last slice.

Set lowZ sets the lower 
limit to the currently-

displayed slice.

Set highZ sets the upper 
limit to the currently-

displayed slice.



Now that you’ve selected your Z limits, you need to select 
the XY area in which you want to segment. Click Select.

Then move your cursor onto the 
image and left-click once on a 

position near your area of interest.

An orange spot should be visible. This 
will be one corner of your rectangular 

selection.

Move to the opposite side of your 
area of interest and left-click a 

second time.

This position will be the diagonally-
opposite corner of your rectangular 

selection. An orange rectangle should 
appear.

If you’re not happy with the area you’ve 
selected. Click Select and try again.



Your cursor is now an eye dropper. Press down on the 
image to pick up the threshold range. The entry fields will 

readjust simultaneously.

Try to pick up all the voxels of the mitochondria.

Oops! If you overshoot and pick up areas 
outside the mitochondrion, just click 

Refresh and reattempt the eye dropping.

Tip: Sometimes the tomogram is too 
grainy and it’s difficult to pick up all the 

desired voxels using the eye dropper.

Turn off View segment and make your 
life easier with the Gaussian blur button.



Each time you click 
Gaussian blur, the 
source image will 
be blurred by one 

standard 
deviation.

A σ of 1 or 2 is 
recommended.

You can restore 
the original image 
with the Restore

button.



Try using the eye dropper cursor 
after applying a Gaussian blur. It 

will be easier to pick up the 
threshold range.

Apply a minimum 
width (optional).

Click Segment.



Fill in the 
remaining gaps 
and press Save

frequently.

Navigate to the folder containing 
your output files. You should have 
noted it down at the start. If not, 

search for the folder contour_files
on your computer.

It should contain a subfolder with 
the workspace name you created.



Open the folder to find these files.

global_segmentation_by_minimum_width contains the global segmentation you ran 
initially (i.e. with the thresholding and 
minimum width parameters but without 
the local segmentations).

global_segmentation_by_threshold contains the global segmentation you ran 
initially but with only the thresholding 
applied.

log_files contains the log files of all processes. A new 
log file is created each time a workspace is 
reopened. This contains parameters such as 
the threshold range and minimum width.

python_files contains files used by the program. Don’t 
touch them.

segmented_volume Contains the up-to-date segmentation.



Each slice is stored as an individual tif
file, with the first indexed as 000.tif 

Open segmented_volume.

Open Fiji to view the slices 
together in a single stack.

Go to File > Import > 
Image Sequence…

Then browse for the 
segmented_volume
folder and click OK.



This will compile all the 
individual tif slices into 

one stack.

You can view the stack as 
a 3D volumetric 

rendering. First, we need 
to adjust the scale of the 

image.

Go to Image > 
Properties…

This tomogram was collected 
with a 9.46 ⨉ 9.46 µm field of 

view, with each voxel being 10 ⨉
10 ⨉ 10 nm. Therefore the slices 
have dimensions of 946 ⨉ 946 
voxels. However, this stack has 

been downsized by a factor of 2 
and has the dimensions 473 ⨉

473 voxels. To maintain the 
proportions between XY and Z, 

you need to downsize the Z scale 
by 2 as well –from 10 nm to 

5nm).

Fill in the dimensions as shown.



After you’ve adjusted the 
scale, go to 

Plugins > 3D Viewer.

Make sure Volume is the 
display option and click 

OK.

You can now view a 3D 
rendering of the 

segmentation and you 
can drag with your cursor 

to rotate the volume.

Although the 
mitochondria are 

complete, there is still a 
bit of noise in the 

segmented volume. Let’s 
get rid of the noise/non-

specific elements.



Go back to the 
Segmented Volume

window.

You need to use manual tools 
to get rid of noise and non-

specific material.

Select Rectangular erase and left-click once
on a point near an area you want to delete.

A red spot should appear and will mark one 
corner of your rectangular selection.

Left click a second time to mark 
the diagonally opposite point 
of your rectangular selection. 

This will delete the segmented 
elements within the rectangle.



Reminder: you can use the Z selection to determine in 
which slices to manually erase segmented material.

You can also do other types of manual edits, including fill 
options.

If you use point options, you can adjust 
the size of the points with this bar.

Erase as much of the noise as you 
can and remember to save 

frequently.

Tip: Don’t stress out over small bits 
of noise like these – they can all be 

deleted in one go later.



If the program starts to become sluggish 
as you make edits, you can reload the 

window to refresh the RAM. Changes will 
be automatically saved first.

Click Reload window



Well, this is embarrassing…

There’s a tiny bug in the program that I 
haven’t got around to fixing: sometimes 
when you click Reload window you get a 

blank window like this. This normally 
happens the first time you do it in a new 
workspace. No biggie. This won’t happen 
again if we reload the workspace. Close 

all the windows.
Open Contour 

again

Click Load workspace

A scrollable dropdown list 
will appear with all your 

saved workspaces, although 
you probably only have one 

right now. 

Select easy_example and 
Open. 

Great, try Reload window again.



Differentiate elements

This tool allows you to 
differentiate separate 

mitochondria and 
quantitate them.



Once you’re happy with your 
segmentation (ignoring small 

bits of noise) click 
Differentiate elements.

You can track the 
progress in the Log 

window.

Once you see this text, the 
process has completed. It 

may still take a few 
moments for the next 

window to load.



The Quantitation window will pop up.

Separate mitochondria 
will be color coded.

Volumes will be calculated 
(in voxel units).

You can use Review elements to 
inspect each element one at time 

in descending order of volume.

Continue moving through 
the list of elements.

Keep clicking on Review 
elements to inspect each 

element one-by-one.



You can also 
click on the 

numbers here 
to jump to 
different 

elements.

In my case, the first non-
specific/noise element has 
a volume of 1326 voxels.

Go back to the 
Segmented Volume window.

Type in a minimum volume 
greater than your largest 
non-specific element…

…then click Filter elements



You can track the progress 
in the Log window.

When it’s complete, scroll 
through the Z stack and the 

small noisy elements 
should have disappeared.



There are new files in the 
output folder.

differentiated_elements contains grayscale 8-bit images of the 
differentiated elements.

differentiated_elements_colored contains RGB images of the color-coded 
differentiated elements, including the size 
filter (if applied).

differentiated_elements_filtered contains grayscale 8-bit images of the 
differentiated elements with the size filter 
applied.

quantitation contains a csv file of the quantitative 
information (volume by default and width if 
selected (more on width later)). If a size 
filter was applied, this folder would only 
contain data for the filtered elements.

quantitation_unfiltered contains a csv file of the quantitative 
information (volume by default and width if 
selected (more on width later). This folder 
is generated if a size filter is applied to back 
up all the quantitative data with the 
filtered-out elements included.

segmented_volume_filtered contains the undifferentiated segmented 
elements after applying the size filter.



Final touches

Polish the segmented 
volume.



Select a color scheme from 
the scroll list and click 
Change color scheme.

Monet is the default 
scheme.

If two neighboring but 
separate mitochondria 

have a very similar shade of 
color, click Shuffle colors to 
mix things up and make the 

distinction clearer.



These changes are automatically 
applied to the files in  

differentiated_elements_colored.

Once you’re happy with the color scheme, 
go to the Segmented Volume window.

Toggle ON/OFF to 
smoothen the edges 

of the segmented 
volume.

Higher smoothing factors 
lead to smoother edges 

but also erode the edges. 
A value of 1 to 3 is 

recommended. Go for 
Factor 3.

Toggle ON/OFF to 
apply a Gaussian blur 

to the segmented 
volume.

Higher standards of 
deviation lead to more 

blur, which can smoothen 
3D renderings of the 

segmented elements. Go 
for Sigma 1.

Hit Apply



A new folder will appear in your output 
directory called 

differentiated_elements_final_touches. 
This will contain the applied smoothing 

and Gaussian blur.

Import this image 
sequence into Fiji as you 

did previously. 

Adjust the scale to 10 nm 
⨉ 10 nm ⨉ 5 nm.

Then load it into 3D 
Viewer. 



You’ve turned it 
from this… …into this!



Difficult example

Let’s try segmenting 
mitochondria from a 

more difficult example.



Open Contour

Let’s create a new workspace with the 
difficult_example.tif file available at 

https://github.com/kamallouisnahas/Contour.

Download the file if you haven’t already. Then 
change the workspace name. 

Click New workspace and select the file.

https://github.com/kamallouisnahas/Contour


This time we get a message we haven’t seen before.

In order to improve the efficiency of the segmentation, any 
source stack larger than 512 ⨉ 512 pixels will be halved in size.

The example tomograms were collected with a 946 ⨉ 946 pixels 
field of view and need to be halved to 473 ⨉ 473.

We didn’t see this message with easy_example.tif because it was 
downsized by a factor of 2 before we opened it in Contour. This 
was done to keep things simpler with the first example.

It’s recommended that you don’t downsize the stacks before
opening them in Contour. If you allow Contour to downsize them, 
it will keep a record of the changes and will account for them 
when it quantitates the segmented elements.

There is only one thing you need to note: you will have to 
downsize the Z scale (from 10 nm to 5 nm) before you produce a 
3D rendering in 3D Viewer with Fiji.

Click OK.



Try to select 
the intensity 
range of the 

mitochondria 
using the Eye 

dropper.

With this tomogram you 
should find it harder to 

run a mitochondria-
specific global 

segmentation on the 
whole tomogram 

because

• the cytoplasm is 
crowded,

• numerous features 
(e.g. vesicles) have a 
similar intensity,

• and the mitochondria 
have a more variable 
intensity.

Don’t attempt the 
Segment function. 

Click Skip.



This will give you a Segmented 
Volume window with a blank 

segmented volume.

In tomograms such as this, it would be easier and 
less time-consuming to use local segmentations 

to segment all the mitochondria. 

If you used global segmentation, you would 
generate a lot of noise and non-specific material 

that would be time-consuming to erase.



Importing volumes

Contour is useful for segmenting 
highly contrasting thick features, such 
as mitochondria or lipid droplets, but 

you might struggle to segment 
thinner features, such as vesicles.

If you segment features in another 
program, you can import the 

segmented volume into Contour to 
quantitate the elements.

Just make sure you save it as an 8-bit 
tif file with background as value 0 

and the segmented elements as any 
positive values.



Download the 
imported_segmentation_example.tif file 

available at 
https://github.com/kamallouisnahas/Contour.

Change the workspace name and click Import 
segmented volume. 

The Segmented Volume window should pop up. 
Click Save and run Differentiate elements.

https://github.com/kamallouisnahas/Contour


Quantitative data about volume will be 
automatically saved for each vesicle in this 
segmented volume. Since the vesicles are 
hollow and open-ended, width is a more 

appropriate measure. Click Calculate width. This 
will calculate the longest width in 3D between 

any two perimeter voxels on each vesicle.

An information window will pop 
to let you know that this function 

will only work reliably on data 
where the original voxel 

dimensions are cubic.

E.g. 10 nm ⨉ 10 nm ⨉ 10 nm for 
the tomograms.

Click Yes.



A second information window 
will pop up to warn you that this 
process can be time-consuming if

• there are a lot of segmented 
elements

• or there are large segmented 
elements with a lot of voxels 
at their perimeters.

This example data should take 
approximately 6 minutes to run. 

Click Yes.

When complete, you can see 2D 
a preview of the widths for all 

the vesicles.



Navigate to the quantitation csv 
file in the output folder and you 
can find the widths reported in 

voxel units.



Segmenting cristae

It is possible to segment 
cristae using Contour but 

there are a few more steps 
you need to do first in Fiji.



Download the file cristae_example.tif from 
https://github.com/kamallouisnahas/Contour.

Open it in Fiji.

Go to Image > Scale…

https://github.com/kamallouisnahas/Contour


Increase the XY scale by 2.5 
times. This will increase the 
voxel width of the cristae to 

make it easier to apply a 
minimum width.



Go to Image > Duplicate…

Duplicate the stack twice and 
rename them Gauss1 and 

Gauss10.



Select Gauss1 and go to 
Process > Filters > Gaussian Blur…

Apply a Sigma of 1.00 
and click OK.

Repeat this for Gauss10 but apply 
a Sigma of 10.



Now we’re going to 
subtract Gauss1 from 
Gauss10 and this will 

increase the signal-to-
background ratio.

Go to Process > Image 
Calculator…

Fill in these fields with a 
Subtract operation.



Adjust the 
brightness/contrast on the 
Result of Gauss10 window.

Go to Edit > Invert.

Try performing local 
segmentations on this 

stack.



You can segment the 
cristae by 

performing local 
segmentations and 

applying a minimum 
width.



Thank you for using Contour

If you have any queries or want 
to report bugs, please email 
contourqueries@gmail.com

mailto:contourqueries@gmail.com

